Clicky

What web browsers are compatible with Campfire?

Campfire requires Internet Explorer, Safari, Chrome, or Firefox. Campfire doesn’t work with Internet Explorer 6.×. Other browsers may or may not work, but only the four listed are guaranteed compatible.

How_did_we_do Help us improve our customer service: Was this article helpful? Yes or No.

Categories: Campfire, Miscellaneous

Need more help?